aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-11-06 16:06:51 +0000
committerNicolas Thill <nico@openwrt.org>2005-11-06 16:06:51 +0000
commit32b56c56c8358cfcfc2ac1a7b1822c4ea35f1830 (patch)
tree92a00f05d735005fdaf2f520fa95536232ede5da /package/Makefile
parent6917bbb93d3831de155b3e31c94c66c6cd4f42b2 (diff)
downloadmaster-187ad058-32b56c56c8358cfcfc2ac1a7b1822c4ea35f1830.tar.gz
master-187ad058-32b56c56c8358cfcfc2ac1a7b1822c4ea35f1830.tar.bz2
master-187ad058-32b56c56c8358cfcfc2ac1a7b1822c4ea35f1830.zip
add snort-wireless package (thanks to Florian Fainelli)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2354 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index bf4e425b59..9b5fe61e98 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -176,6 +176,7 @@ package-$(BR2_COMPILE_SHFS) += shfs
package-$(BR2_PACKAGE_SIPROXD) += siproxd
package-$(BR2_PACKAGE_SIPSAK) += sipsak
package-$(BR2_COMPILE_SNORT) += snort
+package-$(BR2_COMPILE_SNORT_WIRELESS) += snort-wireless
package-$(BR2_PACKAGE_SOCAT) += socat
package-$(BR2_COMPILE_SPEEX) += speex
package-$(BR2_COMPILE_SQLITE) += sqlite
@@ -426,6 +427,17 @@ ifeq ($(BR2_PACKAGE_SNORT_ENABLE_INLINE),y)
snort-compile: iptables-compile
endif
+snort-wireless-compile: libnet-compile libpcap-compile pcre-compile
+ifeq ($(BR2_PACKAGE_SNORT_WIRELESS_WITH_MYSQL),y)
+snort-wireless-compile: mysql-compile
+endif
+ifeq ($(BR2_PACKAGE_SNORT_WIRELESS_WITH_PGSQL),y)
+snort-wireless-compile: postgresql-compile
+endif
+ifeq ($(BR2_PACKAGE_SNORT_WIRELESS_ENABLE_INLINE),y)
+snort-wireless-compile: iptables-compile
+endif
+
ulogd-compile: iptables-compile
ifneq ($(BR2_PACKAGE_ULOGD_MOD_MYSQL),)
ulogd-compile: mysql-compile