aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-26 11:37:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-05-26 11:37:05 +0000
commit13078aa71ea3b9befa3208200aa257996827d013 (patch)
treeebb7916bba33231f889a772bf32684148b8b9864 /package/Makefile
parent1b04c81ab8a0fd8090fe5733a7a0b879c2014d48 (diff)
downloadmaster-187ad058-13078aa71ea3b9befa3208200aa257996827d013.tar.gz
master-187ad058-13078aa71ea3b9befa3208200aa257996827d013.tar.bz2
master-187ad058-13078aa71ea3b9befa3208200aa257996827d013.zip
build: trigger pacakge index creation for all feeds if required
When CONFIG_PER_FEED_REPO_ADD_DISABLED is set, trigger index creation for any available feed, regardless of whether there where binaries built or not. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45765 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index 94b807f5d5..a601dcbb31 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -132,7 +132,11 @@ endif
PACKAGE_SUBDIRS=.
ifneq ($(CONFIG_PER_FEED_REPO),)
- PACKAGE_SUBDIRS=base $(FEEDS_ENABLED)
+ ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
+ PACKAGE_SUBDIRS=base $(FEEDS_AVAILABLE)
+ else
+ PACKAGE_SUBDIRS=base $(FEEDS_ENABLED)
+ endif
endif
$(curdir)/index: FORCE