aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-26 09:09:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-26 09:09:07 +0000
commit0e2a822b3a973a3344d3e496121b3771e0598bea (patch)
treee56724eb1be8ed79bf21db16829c8cf3501787ff /package/Makefile
parent3aa1b8e27b102c73c873e5585251a4bb334375aa (diff)
downloadmaster-187ad058-0e2a822b3a973a3344d3e496121b3771e0598bea.tar.gz
master-187ad058-0e2a822b3a973a3344d3e496121b3771e0598bea.tar.bz2
master-187ad058-0e2a822b3a973a3344d3e496121b3771e0598bea.zip
build: allow creating empty package feeds
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45757 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/Makefile b/package/Makefile
index d5212f09a8..94b807f5d5 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -138,8 +138,8 @@ endif
$(curdir)/index: FORCE
@echo Generating package index...
@for d in $(PACKAGE_SUBDIRS); do ( \
- [ -d $(PACKAGE_DIR)/$$d ] && \
- cd $(PACKAGE_DIR)/$$d || continue; \
+ mkdir -p $(PACKAGE_DIR)/$$d; \
+ cd $(PACKAGE_DIR)/$$d || continue; \
$(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
gzip -9c Packages > Packages.gz; \
); done