aboutsummaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-07-27 22:26:13 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-07-27 22:26:13 +0000
commit0a99e514e78a194a4b561f071af5026e99d6bec7 (patch)
treee3632156f528ea358cd9310435d0638e60546fb4 /package/Makefile
parent947ed3394530f5d02bd4277eb3c59433c108e731 (diff)
downloadmaster-187ad058-0a99e514e78a194a4b561f071af5026e99d6bec7.tar.gz
master-187ad058-0a99e514e78a194a4b561f071af5026e99d6bec7.tar.bz2
master-187ad058-0a99e514e78a194a4b561f071af5026e99d6bec7.zip
[buildsystem] make base-files dependent on opkg host compile, fixes install errors when package/compile and package/install are invoked separately
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22405 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/package/Makefile b/package/Makefile
index 530405cd06..3c7b0b49bc 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -12,6 +12,7 @@ $(curdir)/builddirs:=$(sort $(package-) $(package-y) $(package-m))
ifeq ($(SDK),1)
$(curdir)/builddirs-install:=.
else
+ $(curdir)/base-files/compile += $(curdir)/opkg/host/compile
$(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
$(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
$(curdir)/builddirs-install:=. $(sort $(package-y))
@@ -20,9 +21,6 @@ ifneq ($(IGNORE_ERRORS),)
$(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
endif
-$(curdir)/opkghost: $(TMP_DIR)/.build
- @-$(MAKE) package/opkg/host/install
-
$(curdir)/install:=$(curdir)/install-cleanup
$(curdir)/cleanup: $(TMP_DIR)/.build
@@ -93,8 +91,7 @@ $(curdir)/flags-install:= -j1
$(eval $(call stampfile,$(curdir),package,prereq,.config))
$(eval $(call stampfile,$(curdir),package,cleanup))
$(eval $(call stampfile,$(curdir),package,compile))
-$(eval $(call stampfile,$(curdir),package,opkghost))
-$(eval $(call stampfile,$(curdir),package,install,$(STAGING_DIR)/stamp/.package_opkghost))
+$(eval $(call stampfile,$(curdir),package,install))
$(eval $(call stampfile,$(curdir),package,rootfs-prepare))
$(eval $(call subdir,$(curdir)))