aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2008-05-15 00:57:50 +0000
committerTravis Kemen <thepeople@openwrt.org>2008-05-15 00:57:50 +0000
commitf197ca7979759d8c649da0f904c712389865b092 (patch)
tree257256deb82db59f33f1262aa9f506c7a86c9691 /include
parent2ad42a8a5abfdcb6c193c1883daf80022f86a4cc (diff)
downloadmaster-187ad058-f197ca7979759d8c649da0f904c712389865b092.tar.gz
master-187ad058-f197ca7979759d8c649da0f904c712389865b092.tar.bz2
master-187ad058-f197ca7979759d8c649da0f904c712389865b092.zip
This patch makes kernel modules check if config is defined and creates a config
passthrough target which will evaluate the original config in the generated package. This is done so kernel modules can have configuration menus like busybox, etc... Signed-off-by: Axel Gembe <ago@bastart.eu.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11139 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/kernel.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index b80c3b63ff..7d986e4597 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -120,6 +120,12 @@ $(call KernelPackage/$(1)/description)
endef
endif
+ ifdef KernelPackage/$(1)/config
+ define Package/kmod-$(1)/config
+$(call KernelPackage/$(1)/config)
+ endef
+ endif
+
ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
ifneq ($(strip $(FILES)),)
define Package/kmod-$(1)/install