aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-19 20:30:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-19 20:30:11 +0000
commitef90a4e2f59c414c425131ca0fc15e0056839346 (patch)
tree13f241e2689cdc703a47eea9fd5f552e402b78a6 /include
parent349bcedc1263fd6a79ae593f0a7f96949b3400ee (diff)
downloadmaster-187ad058-ef90a4e2f59c414c425131ca0fc15e0056839346.tar.gz
master-187ad058-ef90a4e2f59c414c425131ca0fc15e0056839346.tar.bz2
master-187ad058-ef90a4e2f59c414c425131ca0fc15e0056839346.zip
autodetect atm, pci, usb, pcmcia features from kernel config file
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5586 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/kernel-build.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 4967dfb67e..8462319f0a 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -8,6 +8,23 @@ KERNEL_BUILD:=1
include $(INCLUDE_DIR)/prereq.mk
+-include ./config
+ifneq ($(CONFIG_ATM),)
+ FEATURES += atm
+endif
+ifneq ($(CONFIG_PCI),)
+ FEATURES += pci
+endif
+ifneq ($(CONFIG_USB),)
+ FEATURES += usb
+endif
+ifneq ($(CONFIG_PCMCIA),)
+ FEATURES += pcmcia
+endif
+
+# remove duplicates
+FEATURES:=$(sort $(FEATURES))
+
# For target profile selection - the default set
DEFAULT_PACKAGES:=base-files libgcc uclibc bridge busybox dnsmasq dropbear iptables mtd ppp ppp-mod-pppoe mtd