aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-03 14:44:30 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-03 14:44:30 +0000
commite9da769c5bdb718f2eef6939bee7d16d6be8b0f1 (patch)
treea75fb58d4b7aaca85351365163a40dc54cad7ba2 /include
parentd329920be50c23e2419002d027a8ec13e394dd45 (diff)
downloadmaster-187ad058-e9da769c5bdb718f2eef6939bee7d16d6be8b0f1.tar.gz
master-187ad058-e9da769c5bdb718f2eef6939bee7d16d6be8b0f1.tar.bz2
master-187ad058-e9da769c5bdb718f2eef6939bee7d16d6be8b0f1.zip
build: for cmake, always use ccache from staging dir instead of relying on the host
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48079 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/cmake.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/include/cmake.mk b/include/cmake.mk
index 4207a4dcee..4e4169a132 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -18,10 +18,7 @@ ifeq ($(CONFIG_CCACHE),)
CMAKE_C_COMPILER_ARG1:=
CMAKE_CXX_COMPILER_ARG1:=
else
- CCACHE:=$(shell which ccache)
- ifeq ($(CCACHE),)
- CCACHE:=$(STAGING_DIR_HOST)/bin/ccache
- endif
+ CCACHE:=$(STAGING_DIR_HOST)/bin/ccache
CMAKE_C_COMPILER:=$(CCACHE)
CMAKE_C_COMPILER_ARG1:=$(TARGET_CC_NOCACHE)
CMAKE_CXX_COMPILER:=$(CCACHE)