aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-25 20:03:20 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-25 20:03:20 +0000
commite51a6a6d99af6765816bf2d1e8b6be8bd0ef0377 (patch)
tree493547a81a0158308ddb8216e6f76592166fea0a /include
parent07b5a8ccf4eb079322bb8a666983e556fb826a3c (diff)
downloadmaster-187ad058-e51a6a6d99af6765816bf2d1e8b6be8bd0ef0377.tar.gz
master-187ad058-e51a6a6d99af6765816bf2d1e8b6be8bd0ef0377.tar.bz2
master-187ad058-e51a6a6d99af6765816bf2d1e8b6be8bd0ef0377.zip
image: generate separate jffs2 images w/o padding
The new root.jffs2-*-raw images can be used for firmware images with custom padding requirements. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38196 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index 2f75e74d69..5d512df38d 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -20,9 +20,9 @@ IMG_PREFIX:=openwrt-$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
MKFS_DEVTABLE_OPT := -D $(INCLUDE_DIR)/device_table.txt
ifneq ($(CONFIG_BIG_ENDIAN),)
- JFFS2OPTS := --pad --big-endian --squash-uids -v
+ JFFS2OPTS := --big-endian --squash-uids -v
else
- JFFS2OPTS := --pad --little-endian --squash-uids -v
+ JFFS2OPTS := --little-endian --squash-uids -v
endif
ifeq ($(CONFIG_JFFS2_RTIME),y)
@@ -84,7 +84,8 @@ endif
define Image/mkfs/jffs2/sub
# FIXME: removing this line will cause strange behaviour in the foreach loop below
- $(STAGING_DIR_HOST)/bin/mkfs.jffs2 $(3) -e $(patsubst %k,%KiB,$(1)) -o $(KDIR)/root.jffs2-$(2) -d $(TARGET_DIR) -v 2>&1 1>/dev/null | awk '/^.+$$$$/'
+ $(STAGING_DIR_HOST)/bin/mkfs.jffs2 $(3) --pad -e $(patsubst %k,%KiB,$(1)) -o $(KDIR)/root.jffs2-$(2) -d $(TARGET_DIR) -v 2>&1 1>/dev/null | awk '/^.+$$$$/'
+ $(STAGING_DIR_HOST)/bin/mkfs.jffs2 $(3) -e $(patsubst %k,%KiB,$(1)) -o $(KDIR)/root.jffs2-$(2)-raw -d $(TARGET_DIR) -v 2>&1 1>/dev/null | awk '/^.+$$$$/'
$(call add_jffs2_mark,$(KDIR)/root.jffs2-$(2))
$(call Image/Build,jffs2-$(2))
endef