aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-20 21:31:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-20 21:31:50 +0000
commitdce52ac66dff0412971646e39c8aa6d5b314dc0e (patch)
treea046e6adad0f101091c0e49c3ddc201f32388034 /include
parentd0e5aa6b62421ac0be1988f5eb0f688c751e5665 (diff)
downloadmaster-187ad058-dce52ac66dff0412971646e39c8aa6d5b314dc0e.tar.gz
master-187ad058-dce52ac66dff0412971646e39c8aa6d5b314dc0e.tar.bz2
master-187ad058-dce52ac66dff0412971646e39c8aa6d5b314dc0e.zip
build: add locking for downloads (fixes race conditions with multiple variants)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48416 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index ca5eee4e02..ffde522923 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -182,6 +182,6 @@ define Download
$(DL_DIR)/$(FILE):
mkdir -p $(DL_DIR)
- $(if $(DownloadMethod/$(call dl_method,$(URL),$(PROTO))),$(DownloadMethod/$(call dl_method,$(URL),$(PROTO))),$(DownloadMethod/unknown))
+ $(call locked,$(if $(DownloadMethod/$(call dl_method,$(URL),$(PROTO))),$(DownloadMethod/$(call dl_method,$(URL),$(PROTO))),$(DownloadMethod/unknown)),$(FILE))
endef