aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-04-09 10:25:34 +0000
committerJohn Crispin <blogic@openwrt.org>2016-04-09 10:25:34 +0000
commitdc1826fb26e4f3024986c902fda568023daa33bc (patch)
tree8ee66184aeb27832a1069893e87d4cb142e1be07 /include
parent84dffdfd635934ecad53dd896b3b8fb5965dd9cb (diff)
downloadmaster-187ad058-dc1826fb26e4f3024986c902fda568023daa33bc.tar.gz
master-187ad058-dc1826fb26e4f3024986c902fda568023daa33bc.tar.bz2
master-187ad058-dc1826fb26e4f3024986c902fda568023daa33bc.zip
download: add @GITHUB download facility
Define a new alias (@GITHUB) for downloading raw github repository files Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49138 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 63af908114..a359514002 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -13,7 +13,7 @@ DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
define dl_method
$(strip \
$(if $(2),$(2), \
- $(if $(filter @APACHE/% @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
+ $(if $(filter @APACHE/% @GITHUB/% @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
$(if $(filter git://%,$(1)),git, \
$(if $(filter svn://%,$(1)),svn, \
$(if $(filter cvs://%,$(1)),cvs, \