aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-18 17:52:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-18 17:52:03 +0000
commitcf04b76ce4039f3feca162c57864db9b98532113 (patch)
treee720b9d3a6299763a6fc2b0db9cdf83389fb1a42 /include
parentd814e20bd4318dfa7ca47561e26e78d916d34086 (diff)
downloadmaster-187ad058-cf04b76ce4039f3feca162c57864db9b98532113.tar.gz
master-187ad058-cf04b76ce4039f3feca162c57864db9b98532113.tar.bz2
master-187ad058-cf04b76ce4039f3feca162c57864db9b98532113.zip
arc: clean-up and move CFLAGS to include/target.mk
Most of currently mentioned CFLAGS in arc770/Makefile are not really required because: [1] "-Os -pipe" are set by default in include/target.mk [2] "-fno-caller-saves" gets enabled via menuconfig as an extra compiler flag for developers So the only one that makes sense is "-matomic" and that one is really essential. Without it many software packges won't build complainin on unresolved atomic ops. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: Jo-Philipp Wich <jow@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48326 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/target.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index f1292987f2..d8c0212cf8 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -263,6 +263,7 @@ ifeq ($(DUMP),1)
endif
ifeq ($(ARCH),arc)
CPU_TYPE ?= arc700
+ CPU_CFLAGS += -matomic
CPU_CFLAGS_arc700 = -marc700
endif
DEFAULT_CFLAGS=$(strip $(CPU_CFLAGS) $(CPU_CFLAGS_$(CPU_TYPE)) $(CPU_CFLAGS_$(CPU_SUBTYPE)))