aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-20 22:25:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-20 22:25:14 +0000
commitab05894193aced320f5bdcfa7ef31fd0f2ba7a8a (patch)
tree7c9909131b52634dd2a050519bf971211b64e7eb /include
parentea1f95483321a5fcc30321fb99c5ea12c88065ec (diff)
downloadmaster-187ad058-ab05894193aced320f5bdcfa7ef31fd0f2ba7a8a.tar.gz
master-187ad058-ab05894193aced320f5bdcfa7ef31fd0f2ba7a8a.tar.bz2
master-187ad058-ab05894193aced320f5bdcfa7ef31fd0f2ba7a8a.zip
disable kmod packages where the KCONFIG options are =y
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8086 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/kernel.mk16
1 files changed, 9 insertions, 7 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index d27f8ac6ac..b758f1db22 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -97,13 +97,15 @@ define KernelPackage
$(call KernelPackage/$(1)/$(BOARD)-$(KERNEL))
endef
- ifneq ($(strip $(FILES)),)
- define Package/kmod-$(1)/install
- mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
- $(CP) -L $$(FILES) $$(1)/lib/modules/$(LINUX_VERSION)/
- $(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))
- $(call KernelPackage/$(1)/install,$$(1))
- endef
+ ifeq ($(filter y,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),)
+ ifneq ($(strip $(FILES)),)
+ define Package/kmod-$(1)/install
+ mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
+ $(CP) -L $$(FILES) $$(1)/lib/modules/$(LINUX_VERSION)/
+ $(call ModuleAutoLoad,$(1),$$(1),$(AUTOLOAD))
+ $(call KernelPackage/$(1)/install,$$(1))
+ endef
+ endif
endif
$$(eval $$(call BuildPackage,kmod-$(1)))