aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-28 22:42:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-28 22:42:34 +0000
commita82f94f5a054ee733b1f9fa630f85ff938190e88 (patch)
treef555103516dd60d641a647758d4288e8fcbbeccb /include
parenteeb64dea12f5802b6580e0dace48e5df876305dc (diff)
downloadmaster-187ad058-a82f94f5a054ee733b1f9fa630f85ff938190e88.tar.gz
master-187ad058-a82f94f5a054ee733b1f9fa630f85ff938190e88.tar.bz2
master-187ad058-a82f94f5a054ee733b1f9fa630f85ff938190e88.zip
include/kernel: add custom USER/DOMAIN config options
These allow the generated kernel's build metadata to be defined explicitly. This metadata is reported, eg, at boot time and in `uname -a` on running systems. If the variables aren't configured, the current build system username and hostname are used as normal. The motivation for this option is to achive reproducible (bit-for-bit identical) kernel builds of official openwrt releases. Signed-off-by: bryan newbold <bnewbold@robocracy.org> Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48541 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/kernel-defaults.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 052b2b3a7b..ae02556058 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -10,6 +10,8 @@ KERNEL_MAKEOPTS := -C $(LINUX_DIR) \
CROSS_COMPILE="$(KERNEL_CROSS)" \
ARCH="$(LINUX_KARCH)" \
KBUILD_HAVE_NLS=no \
+ KBUILD_BUILD_USER="$(call qstrip,$(CONFIG_KERNEL_BUILD_USER))" \
+ KBUILD_BUILD_HOST="$(call qstrip,$(CONFIG_KERNEL_BUILD_DOMAIN))" \
CONFIG_SHELL="$(BASH)" \
$(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='') \
$(if $(PKG_BUILD_ID),LDFLAGS_MODULE=--build-id=0x$(PKG_BUILD_ID))