aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-03-05 10:49:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-03-05 10:49:59 +0000
commita4006429ca68ccd04145c5b6d5dae8e0b8ec3bae (patch)
tree420e1f77b98c341fa3f091a723f0f23b0eb3b867 /include
parentbc12669071599f4b44db66a25eae79620b11c824 (diff)
downloadmaster-187ad058-a4006429ca68ccd04145c5b6d5dae8e0b8ec3bae.tar.gz
master-187ad058-a4006429ca68ccd04145c5b6d5dae8e0b8ec3bae.tar.bz2
master-187ad058-a4006429ca68ccd04145c5b6d5dae8e0b8ec3bae.zip
build: fix git prereq check to not rely on being in a git directory (#21968)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48926 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 23a5b932ed..443b17399d 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -155,7 +155,7 @@ $(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
svn --version | grep Subversion))
$(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
- git submodule update --help 2>&1 | grep -- --recursive))
+ git submodule --help 2>&1 | grep -q -- --recursive))
$(eval $(call SetupHostCommand,file,Please install the 'file' package, \
file --version 2>&1 | grep file))