aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-20 19:12:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-20 19:12:28 +0000
commit6d7af0d09fac8af05ed4c31d826be20c5296d48a (patch)
tree98ae4fdb3dfc3235ad30e528652d0f52b66cab6b /include
parente25f7380b533614948757bbcab510b7536677f27 (diff)
downloadmaster-187ad058-6d7af0d09fac8af05ed4c31d826be20c5296d48a.tar.gz
master-187ad058-6d7af0d09fac8af05ed4c31d826be20c5296d48a.tar.bz2
master-187ad058-6d7af0d09fac8af05ed4c31d826be20c5296d48a.zip
include/autoconf.mk: decouple host fixups from target fixups
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48403 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/autotools.mk14
1 files changed, 4 insertions, 10 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 3316998dc9..3e028fa72d 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -143,27 +143,21 @@ define patch_libtool_host
$(HOST_BUILD_DIR)))
endef
-ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
+ifneq ($(filter patch-libtool-host,$(PKG_FIXUP)),)
Hooks/HostConfigure/Pre += patch_libtool_host
endif
-ifneq ($(filter patch-libtool,$(HOST_FIXUP)),)
+ifneq ($(filter patch-libtool-host,$(HOST_FIXUP)),)
Hooks/HostConfigure/Pre += $(strip $(call patch_libtool,$(HOST_BUILD_DIR)))
endif
-ifneq ($(filter libtool,$(HOST_FIXUP)),)
- ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
- Hooks/HostConfigure/Pre += autoreconf_host
- endif
-endif
-
-ifneq ($(filter libtool-ucxx,$(HOST_FIXUP)),)
+ifneq ($(filter libtool-host,$(HOST_FIXUP)),)
ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
Hooks/HostConfigure/Pre += autoreconf_host
endif
endif
-ifneq ($(filter autoreconf,$(HOST_FIXUP)),)
+ifneq ($(filter autoreconf-host,$(HOST_FIXUP)),)
ifeq ($(filter autoreconf,$(Hooks/HostConfigure/Pre)),)
Hooks/HostConfigure/Pre += autoreconf_host
endif