aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-13 03:35:15 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-13 03:35:15 +0000
commit5f4047589a345c4150a123b575b1abf0723540a5 (patch)
treea893b907acfd5521463d25dd4a6ffb891eab86de /include
parent75f47798f97b184293a96213513b0698c1318b7c (diff)
downloadmaster-187ad058-5f4047589a345c4150a123b575b1abf0723540a5.tar.gz
master-187ad058-5f4047589a345c4150a123b575b1abf0723540a5.tar.bz2
master-187ad058-5f4047589a345c4150a123b575b1abf0723540a5.zip
ubifs: when creating ubi(fs) images profile originated arguments have priority
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38381 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk14
1 files changed, 10 insertions, 4 deletions
diff --git a/include/image.mk b/include/image.mk
index 67cfa4b677..c79d823538 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -121,9 +121,12 @@ endif
ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
define Image/mkfs/ubifs
- ifdef UBIFS_OPTS
+ ifneq ($($(PROFILE)_UBIFS_OPTS)$(UBIFS_OPTS),)
$(STAGING_DIR_HOST)/bin/mkfs.ubifs \
- $(UBIFS_OPTS) \
+ $(if $($(PROFILE)_UBIFS_OPTS), \
+ $(shell echo $($(PROFILE)_UBIFS_OPTS)), \
+ $(shell echo $(UBIFS_OPTS)), \
+ ) \
$(if $(CONFIG_TARGET_UBIFS_FREE_SPACE_FIXUP),--space-fixup) \
$(if $(CONFIG_TARGET_UBIFS_COMPRESSION_NONE),--force-compr=none) \
$(if $(CONFIG_TARGET_UBIFS_COMPRESSION_LZO),--force-compr=lzo) \
@@ -134,11 +137,14 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
endif
$(call Image/Build,ubifs)
- ifdef UBI_OPTS
+ ifneq ($($(PROFILE)_UBI_OPTS)$(UBI_OPTS),)
$(CP) ./ubinize.cfg $(KDIR)
( cd $(KDIR); \
$(STAGING_DIR_HOST)/bin/ubinize \
- $(UBI_OPTS) \
+ $(if $($(PROFILE)_UBI_OPTS), \
+ $(shell echo $($(PROFILE)_UBI_OPTS)), \
+ $(shell echo $(UBI_OPTS)), \
+ ) \
-o $(KDIR)/root.ubi \
ubinize.cfg \
)