aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-12 15:01:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-12 15:01:08 +0000
commit4d934085db7359b7735d7456702b19a3b6206aaf (patch)
tree81861dfd2a8bd63219b3b8ce9646599a589984f3 /include
parent787a1b03f4ac54c8b1ae13c3f978378fa74db3df (diff)
downloadmaster-187ad058-4d934085db7359b7735d7456702b19a3b6206aaf.tar.gz
master-187ad058-4d934085db7359b7735d7456702b19a3b6206aaf.tar.bz2
master-187ad058-4d934085db7359b7735d7456702b19a3b6206aaf.zip
image.mk: remove legacy target rules
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42881 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/image.mk10
1 files changed, 3 insertions, 7 deletions
diff --git a/include/image.mk b/include/image.mk
index 67c9a2f663..12322bdb8d 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -259,10 +259,10 @@ define BuildImage
ifeq ($(IB),)
.PHONY: download prepare compile clean image_prepare mkfs_prepare kernel_prepare install
- compile: compile-targets
+ compile:
$(call Build/Compile)
- clean: clean-targets
+ clean:
$(call Build/Clean)
image_prepare: compile
@@ -279,15 +279,11 @@ define BuildImage
$(foreach fs,$(TARGET_FILESYSTEMS) $(fs-subtypes-y),$(call BuildImage/mkfs,$(fs)))
- install: kernel_prepare install-targets
+ install: kernel_prepare
$(foreach fs,$(TARGET_FILESYSTEMS),
$(call Image/Build,$(fs))
)
$(call Image/mkfs/ubifs)
$(call Image/Checksum)
- compile-targets:
- install-targets:
- clean-targets:
-
endef