aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-02-17 08:44:37 +0000
committerJo-Philipp Wich <jow@openwrt.org>2016-02-17 08:44:37 +0000
commit2c958ed6db5bc4f15168274ada179e1f6304e3d8 (patch)
treefbd674b311b0138a80f0246325947acfd0c94536 /include
parent8ff880aacb3c8e785206c0e6030116c6eda1a808 (diff)
downloadmaster-187ad058-2c958ed6db5bc4f15168274ada179e1f6304e3d8.tar.gz
master-187ad058-2c958ed6db5bc4f15168274ada179e1f6304e3d8.tar.bz2
master-187ad058-2c958ed6db5bc4f15168274ada179e1f6304e3d8.zip
download.mk: fix packed checkout mirroring support
Changeset r48416 broke the downloading of mirrored, packed scm checkouts. Fix this by removing the "@" sign in front of the download command which is now executed as part of a larger shell command under flock. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48733 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 8619734d17..988542f95a 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -48,7 +48,7 @@ define DownloadMethod/default
endef
define wrap_mirror
- $(if $(if $(MIRROR),$(filter-out x,$(MIRROR_MD5SUM))),@$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" "" || ( $(1) ),$(1))
+$(if $(if $(MIRROR),$(filter-out x,$(MIRROR_MD5SUM))),$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(FILE)" "$(MIRROR_MD5SUM)" "" || ( $(1) ),$(1))
endef
define DownloadMethod/cvs