aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2016-02-18 08:22:32 +0000
committerJohn Crispin <blogic@openwrt.org>2016-02-18 08:22:32 +0000
commit2b12dc6530da8d4045af0c81dff67b022e9718ae (patch)
treec84318ce5e3a10a11a7b5cd117f612c5c86b3553 /include
parentd698d2584beff7860f1784873d1e97038620528a (diff)
downloadmaster-187ad058-2b12dc6530da8d4045af0c81dff67b022e9718ae.tar.gz
master-187ad058-2b12dc6530da8d4045af0c81dff67b022e9718ae.tar.bz2
master-187ad058-2b12dc6530da8d4045af0c81dff67b022e9718ae.zip
linux: add support of Synopsys ARCHS38-based boards
This patch introduces support of new boards with ARC HS38 cores. ARC HS38 is a new generation of ARC cores which utilize ARCv2 ISA. As with ARC770 we're addind support for 2 boards for now: [1] Synopsys SDP board (AXS103) This is the same base-board as in AXS101 but with FPGA-based CPU-tile where ARCHs38 core is implemented. [2] nSIM Again this is the same simulation engine but configured for new instruction set and features of new CPU. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Felix Fietkau <nbd@openwrt.org> Cc: Jo-Philipp Wich <jow@openwrt.org> Cc: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48740 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/target.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 54ee463477..42febfca7b 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -265,6 +265,7 @@ ifeq ($(DUMP),1)
CPU_TYPE ?= arc700
CPU_CFLAGS += -matomic
CPU_CFLAGS_arc700 = -marc700
+ CPU_CFLAGS_archs = -marchs
endif
DEFAULT_CFLAGS=$(strip $(CPU_CFLAGS) $(CPU_CFLAGS_$(CPU_TYPE)) $(CPU_CFLAGS_$(CPU_SUBTYPE)))
endif