aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-08 23:06:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-08 23:06:59 +0000
commit089a9af70523d5efd9bae73d3ff692841bb14460 (patch)
tree1b30d6a0e6e338929b17fd02ef83fa6326c726e6 /include
parentaf5f69e6cf5d6cac418dd076a8436763062f1c3e (diff)
downloadmaster-187ad058-089a9af70523d5efd9bae73d3ff692841bb14460.tar.gz
master-187ad058-089a9af70523d5efd9bae73d3ff692841bb14460.tar.bz2
master-187ad058-089a9af70523d5efd9bae73d3ff692841bb14460.zip
build: do not allow the SDK to reconfigure built-in kernel modules
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48155 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/scan.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/include/scan.mk b/include/scan.mk
index 5af035972f..00cfe31fba 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -26,8 +26,12 @@ define feedname
$(if $(patsubst feeds/%,,$(1)),,$(word 2,$(subst /, ,$(1))))
endef
+ifdef SDK
+ IGNORE_PACKAGES = linux
+endif
+
define PackageDir
- $(TMP_DIR)/.$(SCAN_TARGET): $(TMP_DIR)/info/.$(SCAN_TARGET)-$(1)
+ $(if $(filter $(addprefix %_,$(IGNORE_PACKAGES)),$(1)),,$(TMP_DIR)/.$(SCAN_TARGET): $(TMP_DIR)/info/.$(SCAN_TARGET)-$(1))
$(TMP_DIR)/info/.$(SCAN_TARGET)-$(1): $(SCAN_DIR)/$(2)/Makefile $(SCAN_STAMP) $(foreach DEP,$(DEPS_$(SCAN_DIR)/$(2)/Makefile) $(SCAN_DEPS),$(wildcard $(if $(filter /%,$(DEP)),$(DEP),$(SCAN_DIR)/$(2)/$(DEP))))
{ \
$$(call progress,Collecting $(SCAN_NAME) info: $(SCAN_DIR)/$(2)) \