aboutsummaryrefslogtreecommitdiffstats
path: root/include/version.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-23 13:09:50 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-23 13:09:50 +0000
commit8b112e53060f8dcc77c45995cc0624dcc82c7688 (patch)
tree72e7d7dc82e8a6d40a5bde847e5136991f025eb6 /include/version.mk
parentdacc8f2889d24159debabb8dc49bccd7586a4aa0 (diff)
downloadmaster-187ad058-8b112e53060f8dcc77c45995cc0624dcc82c7688.tar.gz
master-187ad058-8b112e53060f8dcc77c45995cc0624dcc82c7688.tar.bz2
master-187ad058-8b112e53060f8dcc77c45995cc0624dcc82c7688.zip
Revert "version.mk: add "%s" placeholder for dotted target.subtarget notation"
This reverts commit d388882dccc1b25575939c3713b3ab394c371fd0. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44090 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/version.mk')
-rw-r--r--include/version.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/include/version.mk b/include/version.mk
index d4addd608f..c4747f236f 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -30,7 +30,7 @@ VERSION_NICK:=$(call qstrip_escape,$(CONFIG_VERSION_NICK))
VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
VERSION_REPO:=$(call qstrip_escape,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%s/packages)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%T/packages)
VERSION_DIST:=$(call qstrip_escape,$(CONFIG_VERSION_DIST))
VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
@@ -79,7 +79,6 @@ VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
-e 's,%R,$(REVISION),g' \
-e 's,%T,$(BOARD),g' \
-e 's,%S,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic),g' \
- -e 's,%s,$(BOARD)$(if $(SUBTARGET),.$(SUBTARGET)),g' \
-e 's,%t,$(VERSION_TAINTS),g' \
-e 's,%M,$(VERSION_MANUFACTURER),g' \
-e 's,%P,$(VERSION_PRODUCT),g' \