aboutsummaryrefslogtreecommitdiffstats
path: root/include/version.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-08 12:46:37 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 12:46:37 +0000
commit2aa90929e631b5fba153c8dd1c5252ed74052054 (patch)
tree11f1efd78f8bf6709a7fd9191771a3d01f7dd6f5 /include/version.mk
parentc3f870fa11b8d15e1cb3bc46efdefc4fcc6e001f (diff)
downloadmaster-187ad058-2aa90929e631b5fba153c8dd1c5252ed74052054.tar.gz
master-187ad058-2aa90929e631b5fba153c8dd1c5252ed74052054.tar.bz2
master-187ad058-2aa90929e631b5fba153c8dd1c5252ed74052054.zip
version.mk: add "%s" placeholder for dotted target.subtarget notation
Implement "%s" placeholder that expands to either the target name, e.g. "ar71xx" if the subtarget is generic or to target.subtarget, e.g. "ar71xx.nand" is a subtarget is choosen. Also change the default repository url template to use "%s" instead of "%T" to reflect the directory structure used by the buildbot systems. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43871 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/version.mk')
-rw-r--r--include/version.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/version.mk b/include/version.mk
index c4747f236f..d4addd608f 100644
--- a/include/version.mk
+++ b/include/version.mk
@@ -30,7 +30,7 @@ VERSION_NICK:=$(call qstrip_escape,$(CONFIG_VERSION_NICK))
VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
VERSION_REPO:=$(call qstrip_escape,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%T/packages)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%s/packages)
VERSION_DIST:=$(call qstrip_escape,$(CONFIG_VERSION_DIST))
VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
@@ -79,6 +79,7 @@ VERSION_SED:=$(SED) 's,%U,$(VERSION_REPO),g' \
-e 's,%R,$(REVISION),g' \
-e 's,%T,$(BOARD),g' \
-e 's,%S,$(BOARD)/$(if $(SUBTARGET),$(SUBTARGET),generic),g' \
+ -e 's,%s,$(BOARD)$(if $(SUBTARGET),.$(SUBTARGET)),g' \
-e 's,%t,$(VERSION_TAINTS),g' \
-e 's,%M,$(VERSION_MANUFACTURER),g' \
-e 's,%P,$(VERSION_PRODUCT),g' \