aboutsummaryrefslogtreecommitdiffstats
path: root/include/verbose.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-17 21:12:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-17 21:12:02 +0000
commit62e361dbf255b4a7b7b8839ef1c05eb844f04f51 (patch)
tree26d2faea684ebed18b111827830dc97c2e01b5b4 /include/verbose.mk
parent77a736a2b6a48ae5c915af94057e55e257859cc8 (diff)
downloadmaster-187ad058-62e361dbf255b4a7b7b8839ef1c05eb844f04f51.tar.gz
master-187ad058-62e361dbf255b4a7b7b8839ef1c05eb844f04f51.tar.bz2
master-187ad058-62e361dbf255b4a7b7b8839ef1c05eb844f04f51.zip
build: make the color of the 'configuration out of sync' warning red to make it harder for users to overlook
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36082 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/verbose.mk')
-rw-r--r--include/verbose.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/verbose.mk b/include/verbose.mk
index 2e8ace442e..d34f55fc48 100644
--- a/include/verbose.mk
+++ b/include/verbose.mk
@@ -27,6 +27,7 @@ endif
ifeq ($(IS_TTY),1)
ifneq ($(strip $(NO_COLOR)),1)
_Y:=\\033[33m
+ _R:=\\033[31m
_N:=\\033[m
endif
endif
@@ -36,6 +37,10 @@ ifeq ($(findstring s,$(OPENWRT_VERBOSE)),)
printf "$(_Y)%s$(_N)\n" "$(1)" >&8
endef
+ define ERROR_MESSAGE
+ printf "$(_R)%s$(_N)\n" "$(1)" >&8
+ endef
+
ifeq ($(QUIET),1)
ifneq ($(CURDIR),$(TOPDIR))
_DIR:=$(patsubst $(TOPDIR)/%,%,${CURDIR})
@@ -58,4 +63,5 @@ else
define MESSAGE
printf "%s\n" "$(1)"
endef
+ ERROR_MESSAGE=$(MESSAGE)
endif