aboutsummaryrefslogtreecommitdiffstats
path: root/include/verbose.mk
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2006-06-23 21:47:24 +0000
committerMike Baker <mbm@openwrt.org>2006-06-23 21:47:24 +0000
commit57013b9f30d4d149448abe2213c000d1dea3b93c (patch)
treecc874bf88aadf09709a732edc3e8807e5fc60c5b /include/verbose.mk
parent1f3a32108b3e36d0613194b9fd356433e515ccb3 (diff)
downloadmaster-187ad058-57013b9f30d4d149448abe2213c000d1dea3b93c.tar.gz
master-187ad058-57013b9f30d4d149448abe2213c000d1dea3b93c.tar.bz2
master-187ad058-57013b9f30d4d149448abe2213c000d1dea3b93c.zip
switch on new verbose system
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4064 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/verbose.mk')
-rw-r--r--include/verbose.mk20
1 files changed, 14 insertions, 6 deletions
diff --git a/include/verbose.mk b/include/verbose.mk
index 77a877efe3..31e0cea1b3 100644
--- a/include/verbose.mk
+++ b/include/verbose.mk
@@ -1,14 +1,19 @@
# OpenWrt.org 2006
# $Id:$
-ifeq ($(DUMP),)
- ifndef KBUILD_VERBOSE
- KBUILD_VERBOSE=0
- ifeq ("$(origin V)", "command line")
- KBUILD_VERBOSE=$(V)
- endif
+ifndef KBUILD_VERBOSE
+ ifeq ($(DUMP),)
+ KBUILD_VERBOSE=1
+ else
+ KBUILD_VERBOSE=99
+ endif
+ ifeq ("$(origin V)", "command line")
+ KBUILD_VERBOSE=$(V)
endif
+endif
+
+ifneq ($(KBUILD_VERBOSE),99)
ifeq ($(QUIET),1)
$(MAKECMDGOALS): trace
trace: FORCE
@@ -18,6 +23,9 @@ ifeq ($(DUMP),)
}
else
export QUIET:=1
+ ifeq ($(KBUILD_VERBOSE),0)
+ MAKE:=&>/dev/null $(MAKE)
+ endif
MAKE:=3>&1 4>&2 $(MAKE)
endif