aboutsummaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-04 16:27:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-04 16:27:11 +0000
commita976a6d4b420918c3260789d7acef81ac4a0173b (patch)
treeae5182d46ee97cda043762bfbc303a96cf71a2b9 /include/unpack.mk
parent95d308680b9b69996543041c464f2a528578cc4e (diff)
downloadmaster-187ad058-a976a6d4b420918c3260789d7acef81ac4a0173b.tar.gz
master-187ad058-a976a6d4b420918c3260789d7acef81ac4a0173b.tar.bz2
master-187ad058-a976a6d4b420918c3260789d7acef81ac4a0173b.zip
add a crlf workaround similar to the one from freewrt
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6507 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index e533476b52..7813e3b3d3 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -17,4 +17,7 @@ ifeq ($(strip $(PKG_UNPACK)),)
else
# try to autodetect file type
endif
+ ifneq ($(strip $(CRLF_WORKAROUND)),)
+ PKG_UNPACK += && find $(PKG_BUILD_DIR) -type f -print0 | xargs -0 perl -pi -e 's!\r$$$$!!g'
+ endif
endif