aboutsummaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-11 19:07:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-11 19:07:12 +0000
commit916382168371178c24cd4b9550b200f940496131 (patch)
tree929e2eebe75038e2423b67190926876449633692 /include/unpack.mk
parentb61d93d400466118c1be20e734de344d57da79da (diff)
downloadmaster-187ad058-916382168371178c24cd4b9550b200f940496131.tar.gz
master-187ad058-916382168371178c24cd4b9550b200f940496131.tar.bz2
master-187ad058-916382168371178c24cd4b9550b200f940496131.zip
fix unpacking of .zip files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6083 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index 94124e9ec6..e533476b52 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -8,7 +8,7 @@ ifeq ($(strip $(PKG_UNPACK)),)
# use existing PKG_CAT
PKG_UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | $(HOST_TAR) -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS)
ifeq ($(PKG_CAT),unzip)
- PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
+ PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR)/.. $(DL_DIR)/$(PKG_SOURCE)
endif
# replace zcat with $(ZCAT), because some system have it as gzcat
ifeq ($(PKG_CAT),zcat)