aboutsummaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-14 00:40:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-14 00:40:27 +0000
commit75d681665a26ee9733542b8e5c32e9ba1bae4dcc (patch)
tree5740afd664000225e2cfb54e51686fcf72ab0d66 /include/unpack.mk
parent96c14a07ed71679c0f58500a4e20e8f1ffe0cc41 (diff)
downloadmaster-187ad058-75d681665a26ee9733542b8e5c32e9ba1bae4dcc.tar.gz
master-187ad058-75d681665a26ee9733542b8e5c32e9ba1bae4dcc.tar.bz2
master-187ad058-75d681665a26ee9733542b8e5c32e9ba1bae4dcc.zip
move common unpacking code to unpack.mk, replace zcat with $(ZCAT) for systems that use gzcat instead
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5070 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
new file mode 100644
index 0000000000..6449981c1b
--- /dev/null
+++ b/include/unpack.mk
@@ -0,0 +1,15 @@
+ifeq ($(strip $(PKG_UNPACK)),)
+ ifneq ($(strip $(PKG_CAT)),)
+ # use existing PKG_CAT
+ UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+ ifeq ($(PKG_CAT),unzip)
+ UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
+ endif
+ # replace zcat with $(ZCAT), because some system have it as gzcat
+ ifeq ($(PKG_CAT),zcat)
+ UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+ endif
+ else
+ # try to autodetect file type
+ endif
+endif