aboutsummaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 18:27:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 18:27:53 +0000
commit5513e64b4b1133351dfb29ac42c80f5641ce2324 (patch)
tree490a4cfc5671a07fdac1c43597122fde2df5b44f /include/unpack.mk
parent661b44661104a78eb758da7d197ba187eb60d436 (diff)
downloadmaster-187ad058-5513e64b4b1133351dfb29ac42c80f5641ce2324.tar.gz
master-187ad058-5513e64b4b1133351dfb29ac42c80f5641ce2324.tar.bz2
master-187ad058-5513e64b4b1133351dfb29ac42c80f5641ce2324.zip
only define unpack templates if PKG_SOURCE is set
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14623 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index ae8cdecb27..e2810944e8 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -16,7 +16,8 @@ UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)
ifeq ($(PKG_SOURCE),)
PKG_UNPACK ?= true
-endif
+else
+
ifeq ($(strip $(UNPACK_CMD)),)
ifeq ($(strip $(PKG_CAT)),)
# try to autodetect file type
@@ -64,9 +65,13 @@ ifeq ($(strip $(UNPACK_CMD)),)
CRLF_CMD :=
endif
endif
+
ifdef PKG_BUILD_DIR
PKG_UNPACK := $(call UNPACK_CMD,$(PKG_BUILD_DIR)) $(call CRLF_CMD,$(PKG_BUILD_DIR))
endif
ifdef HOST_BUILD_DIR
HOST_UNPACK := $(call UNPACK_CMD,$(HOST_BUILD_DIR)) $(call CRLF_CMD,$(HOST_BUILD_DIR))
endif
+
+endif # PKG_SOURCE
+