aboutsummaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-14 13:04:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-14 13:04:50 +0000
commit31512673e9feb644be7a7ad6ec4399e62ae48a57 (patch)
tree40d43c1217544bac37412a1336b55625435f4ead /include/unpack.mk
parent0b5410c8d0ce91952764245a44bacbdcb934aad5 (diff)
downloadmaster-187ad058-31512673e9feb644be7a7ad6ec4399e62ae48a57.tar.gz
master-187ad058-31512673e9feb644be7a7ad6ec4399e62ae48a57.tar.bz2
master-187ad058-31512673e9feb644be7a7ad6ec4399e62ae48a57.zip
fix mistakes in unpack change
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5077 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index 6449981c1b..52764e492e 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -1,13 +1,13 @@
ifeq ($(strip $(PKG_UNPACK)),)
ifneq ($(strip $(PKG_CAT)),)
# use existing PKG_CAT
- UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+ PKG_UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
ifeq ($(PKG_CAT),unzip)
- UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
+ PKG_UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
endif
# replace zcat with $(ZCAT), because some system have it as gzcat
ifeq ($(PKG_CAT),zcat)
- UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+ PKG_UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
endif
else
# try to autodetect file type