aboutsummaryrefslogtreecommitdiffstats
path: root/include/unpack.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:37 +0000
commit14be67809466ef612e619b7d8b1e8df42b4e075b (patch)
tree016fc4de832be636e9af52b9bebfc45308c65194 /include/unpack.mk
parent6e39367d4faefe4d03e91495f9a174019bd8ddab (diff)
downloadmaster-187ad058-14be67809466ef612e619b7d8b1e8df42b4e075b.tar.gz
master-187ad058-14be67809466ef612e619b7d8b1e8df42b4e075b.tar.bz2
master-187ad058-14be67809466ef612e619b7d8b1e8df42b4e075b.zip
speed up the build system by including include/shell.sh on shell commands only where necessary
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22720 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/unpack.mk')
-rw-r--r--include/unpack.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/unpack.mk b/include/unpack.mk
index 0151675777..2d35863095 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -71,10 +71,10 @@ ifeq ($(strip $(UNPACK_CMD)),)
endif
ifdef PKG_BUILD_DIR
- PKG_UNPACK ?= $(call UNPACK_CMD,$(PKG_BUILD_DIR)) $(call CRLF_CMD,$(PKG_BUILD_DIR))
+ PKG_UNPACK ?= $(SH_FUNC) $(call UNPACK_CMD,$(PKG_BUILD_DIR)) $(call CRLF_CMD,$(PKG_BUILD_DIR))
endif
ifdef HOST_BUILD_DIR
- HOST_UNPACK ?= $(call UNPACK_CMD,$(HOST_BUILD_DIR)) $(call CRLF_CMD,$(HOST_BUILD_DIR))
+ HOST_UNPACK ?= $(SH_FUNC) $(call UNPACK_CMD,$(HOST_BUILD_DIR)) $(call CRLF_CMD,$(HOST_BUILD_DIR))
endif
endif # PKG_SOURCE