aboutsummaryrefslogtreecommitdiffstats
path: root/include/uclibc++.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-14 20:26:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-14 20:26:04 +0000
commit0ec23389f8d1ffe5e78d2b91f16a5b2d1202cabd (patch)
tree1d1c315a271b098592c1dd1756b91a5117d85c1c /include/uclibc++.mk
parent8ef94e67c30efa29aa74956a981a9aee4a75dac9 (diff)
downloadmaster-187ad058-0ec23389f8d1ffe5e78d2b91f16a5b2d1202cabd.tar.gz
master-187ad058-0ec23389f8d1ffe5e78d2b91f16a5b2d1202cabd.tar.bz2
master-187ad058-0ec23389f8d1ffe5e78d2b91f16a5b2d1202cabd.zip
build: add a config option for choosing the prefered standard c++ library and add uclibc++.mk to make this easy to handle in packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32369 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/uclibc++.mk')
-rw-r--r--include/uclibc++.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/include/uclibc++.mk b/include/uclibc++.mk
new file mode 100644
index 0000000000..817484377f
--- /dev/null
+++ b/include/uclibc++.mk
@@ -0,0 +1,12 @@
+ifndef DUMP
+ ifdef __package_mk
+ $(error uclibc++.mk must be included before package.mk)
+ endif
+endif
+
+PKG_PREPARED_DEPENDS += CONFIG_USE_UCLIBCXX
+CXX_DEPENDS = +USE_UCLIBCXX:uclibcxx +USE_LIBSTDCXX:libstdcpp
+
+ifneq ($(CONFIG_USE_UCLIBCXX),)
+ TARGET_CXX="g++-uc"
+endif