aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-10-28 15:15:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-10-28 15:15:09 +0000
commite3a909038d9ce69e7d582755732569355f490629 (patch)
treeb3d6db7e4ca0c7a3ee692d7747e964357486c368 /include/toplevel.mk
parent7d9a6a4129900aec6013eb9ab37bc6901abf9569 (diff)
downloadmaster-187ad058-e3a909038d9ce69e7d582755732569355f490629.tar.gz
master-187ad058-e3a909038d9ce69e7d582755732569355f490629.tar.bz2
master-187ad058-e3a909038d9ce69e7d582755732569355f490629.zip
build: fix build on Mac OS X 10.9
Add a wrapper around the clang gcc emulation to fix -print-file-name=<lib> Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38560 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk11
1 files changed, 9 insertions, 2 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index a623be9f2e..23d70ac81a 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -43,6 +43,13 @@ unexport LPATH
# make sure that a predefined CFLAGS variable does not disturb packages
export CFLAGS=
+ifneq ($(shell $(HOSTCC) 2>&1 | grep clang),)
+ export HOSTCC_REAL?=$(HOSTCC)
+ export HOSTCC_WRAPPER:=$(TOPDIR)/scripts/clang-gcc-wrapper
+else
+ export HOSTCC_WRAPPER:=$(HOSTCC)
+endif
+
ifeq ($(FORCE),)
.config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
endif
@@ -74,12 +81,12 @@ prepare-tmpinfo: FORCE
fi
scripts/config/mconf:
- @$(_SINGLE)$(SUBMAKE) -s -C scripts/config all CC="$(HOSTCC)"
+ @$(_SINGLE)$(SUBMAKE) -s -C scripts/config all CC="$(HOSTCC_WRAPPER)"
$(eval $(call rdep,scripts/config,scripts/config/mconf))
scripts/config/conf:
- @$(_SINGLE)$(SUBMAKE) -s -C scripts/config conf CC="$(HOSTCC)"
+ @$(_SINGLE)$(SUBMAKE) -s -C scripts/config conf CC="$(HOSTCC_WRAPPER)"
config: scripts/config/conf prepare-tmpinfo FORCE
$< Config.in