aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-01-24 15:36:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2016-01-24 15:36:05 +0000
commitc18a81fd6d9fffb0da4f81e557f79120c1592c89 (patch)
treee7fda7faf2c757e86ec6811f74b28ac152d26950 /include/toplevel.mk
parentd49ca69e9141b4414557807f7c56cc408156b54d (diff)
downloadmaster-187ad058-c18a81fd6d9fffb0da4f81e557f79120c1592c89.tar.gz
master-187ad058-c18a81fd6d9fffb0da4f81e557f79120c1592c89.tar.bz2
master-187ad058-c18a81fd6d9fffb0da4f81e557f79120c1592c89.zip
include: group kmod ipk files into a "kernel" subdirectory
This is useful to just use the kmods from an official build while supplying base packages from a custom feed or the other way around; for just overriding the kmods with a local repo while using official repos for the rest. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48475 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index d13a37013c..0cba07c6e6 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -84,9 +84,9 @@ prepare-tmpinfo: FORCE
f=tmp/.$${type}info; t=tmp/.config-$${type}.in; \
[ "$$t" -nt "$$f" ] || ./scripts/metadata.pl $(_ignore) $${type}_config "$$f" > "$$t" || { rm -f "$$t"; echo "Failed to build $$t"; false; break; }; \
done
- [ tmp/.config-feeds.in -nt tmp/.packagefeeds ] || ./scripts/feeds feed_config > tmp/.config-feeds.in
+ [ tmp/.config-feeds.in -nt tmp/.packagesubdirs ] || ./scripts/feeds feed_config > tmp/.config-feeds.in
./scripts/metadata.pl package_mk tmp/.packageinfo > tmp/.packagedeps || { rm -f tmp/.packagedeps; false; }
- ./scripts/metadata.pl package_feeds tmp/.packageinfo > tmp/.packagefeeds || { rm -f tmp/.packagefeeds; false; }
+ ./scripts/metadata.pl package_subdirs tmp/.packageinfo > tmp/.packagesubdirs || { rm -f tmp/.packagesubdirs; false; }
touch $(TOPDIR)/tmp/.build
.config: ./scripts/config/conf $(if $(CONFIG_HAVE_DOT_CONFIG),,prepare-tmpinfo)