aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-17 21:12:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-17 21:12:02 +0000
commit62e361dbf255b4a7b7b8839ef1c05eb844f04f51 (patch)
tree26d2faea684ebed18b111827830dc97c2e01b5b4 /include/toplevel.mk
parent77a736a2b6a48ae5c915af94057e55e257859cc8 (diff)
downloadmaster-187ad058-62e361dbf255b4a7b7b8839ef1c05eb844f04f51.tar.gz
master-187ad058-62e361dbf255b4a7b7b8839ef1c05eb844f04f51.tar.bz2
master-187ad058-62e361dbf255b4a7b7b8839ef1c05eb844f04f51.zip
build: make the color of the 'configuration out of sync' warning red to make it harder for users to overlook
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36082 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 0918298b16..5e8e6dd1ba 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -9,6 +9,8 @@
RELEASE:=Barrier Breaker
PREP_MK= OPENWRT_BUILD= QUIET=0
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
+
include $(TOPDIR)/include/verbose.mk
ifeq ($(SDK),1)
@@ -22,7 +24,6 @@ OPENWRTVERSION:=$(RELEASE)$(if $(REVISION), ($(REVISION)))
export RELEASE
export REVISION
export OPENWRTVERSION
-export IS_TTY=$(shell tty -s && echo 1 || echo 0)
export LD_LIBRARY_PATH:=$(subst ::,:,$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib)
export DYLD_LIBRARY_PATH:=$(subst ::,:,$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib)
export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
@@ -148,7 +149,7 @@ prereq:: prepare-tmpinfo .config
cp .config tmp/.config; \
./scripts/config/conf -D tmp/.config -w tmp/.config Config.in > /dev/null 2>&1; \
if ./scripts/kconfig.pl '>' .config tmp/.config | grep -q CONFIG; then \
- echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!" >&2; \
+ printf "$(_R)WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!$(_N)\n" >&2; \
fi \
)
@+$(ULIMIT_FIX) $(SUBMAKE) -r $@