aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-08 22:54:19 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-08 22:54:19 +0000
commit5f98f96407ccfd7f3692de0a3b9dba0f2ccf10bb (patch)
treec1c16f88e2083ff6c0bebb9607fcd67c35c6fa24 /include/toplevel.mk
parent9e9fee4f2ac6bf82e6e5bc5245d9d93319646a68 (diff)
downloadmaster-187ad058-5f98f96407ccfd7f3692de0a3b9dba0f2ccf10bb.tar.gz
master-187ad058-5f98f96407ccfd7f3692de0a3b9dba0f2ccf10bb.tar.bz2
master-187ad058-5f98f96407ccfd7f3692de0a3b9dba0f2ccf10bb.zip
include: remove SDK specific target from toplevel.mk
Instead introduce a generic "make prepare" target which is executed if include/prepare.mk exists. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44329 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 0b8a658c18..67357b033a 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -136,13 +136,19 @@ kernel_menuconfig: prepare_kernel_conf
kernel_nconfig: prepare_kernel_conf
$(_SINGLE)$(NO_TRACE_MAKE) -C target/linux nconfig
-tmp/.prereq-build: $(if $(SDK),.git/config) include/prereq-build.mk
+tmp/.prereq-build: include/prereq-build.mk
mkdir -p tmp
rm -f tmp/.host.mk
@$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
echo "Prerequisite check failed. Use FORCE=1 to override."; \
false; \
}
+ ifneq ($(realpath $(TOPDIR)/include/prepare.mk),)
+ @$(_SINGLE)$(NO_TRACE_MAKE) -j1 -r -s -f $(TOPDIR)/include/prepare.mk prepare 2>/dev/null || { \
+ echo "Preparation failed."; \
+ false; \
+ }
+ endif
touch $@
printdb: FORCE