aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-07-17 11:37:20 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-07-17 11:37:20 +0000
commit5f6ce511add3ac9b5af8dec339165cdbf1a65f9d (patch)
tree175cbd25927e76e37d991319af3150c79d799823 /include/toplevel.mk
parentceaf354f7c2a5a894e603a8ebed3c2cf6e9db697 (diff)
downloadmaster-187ad058-5f6ce511add3ac9b5af8dec339165cdbf1a65f9d.tar.gz
master-187ad058-5f6ce511add3ac9b5af8dec339165cdbf1a65f9d.tar.bz2
master-187ad058-5f6ce511add3ac9b5af8dec339165cdbf1a65f9d.zip
toplevel.mk: fix LD_LIBRARY_PATH for host binaries
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46394 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index bbeb7ebcef..11b2dd9e29 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -24,8 +24,8 @@ OPENWRTVERSION:=$(RELEASE)$(if $(REVISION), ($(REVISION)))
export RELEASE
export REVISION
export OPENWRTVERSION
-export LD_LIBRARY_PATH:=$(subst ::,:,$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib)
-export DYLD_LIBRARY_PATH:=$(subst ::,:,$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib)
+export LD_LIBRARY_PATH:=$(subst ::,:,$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(TOPDIR)/staging_dir/host/lib)
+export DYLD_LIBRARY_PATH:=$(subst ::,:,$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(TOPDIR)/staging_dir/host/lib)
export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
export MAKE_JOBSERVER=$(filter --jobserver%,$(MAKEFLAGS))