aboutsummaryrefslogtreecommitdiffstats
path: root/include/toplevel.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-04 00:54:33 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-04 00:54:33 +0000
commit208c6ce2179645ccceea309490a004d487e9929f (patch)
treef67d0dcac867ed9c4781bbd2f59cf1889b4cb22d /include/toplevel.mk
parent2e4239ef70303996ff296302fdc1b63943218500 (diff)
downloadmaster-187ad058-208c6ce2179645ccceea309490a004d487e9929f.tar.gz
master-187ad058-208c6ce2179645ccceea309490a004d487e9929f.tar.bz2
master-187ad058-208c6ce2179645ccceea309490a004d487e9929f.zip
toplevel: add a warning about .config being out of sync after an update
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26459 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/toplevel.mk')
-rw-r--r--include/toplevel.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index e9384aebca..b215e41afd 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -133,6 +133,13 @@ prereq:: prepare-tmpinfo .config
@+$(NO_TRACE_MAKE) -r -s $@
%::
+ @( \
+ cp .config tmp/.config; \
+ ./scripts/config/conf -D tmp/.config -w tmp/.config Config.in > /dev/null 2>&1; \
+ if ./scripts/kconfig.pl '>' .config tmp/.config | grep -q CONFIG; then \
+ echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!"; \
+ fi \
+ )
@+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
@+$(SUBMAKE) -r $@