aboutsummaryrefslogtreecommitdiffstats
path: root/include/toolchain-build.mk
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-10-03 12:54:07 +0000
committerMichael Büsch <mb@bu3sch.de>2010-10-03 12:54:07 +0000
commitef39b40498680c5f29fffbeb88fef3e96b1d33b6 (patch)
tree940cf0a57c57d5fee01760097f72c7790584ef3e /include/toolchain-build.mk
parentf47c187bda4e5cc3ba492800fb4cc2073f8230a2 (diff)
downloadmaster-187ad058-ef39b40498680c5f29fffbeb88fef3e96b1d33b6.tar.gz
master-187ad058-ef39b40498680c5f29fffbeb88fef3e96b1d33b6.tar.bz2
master-187ad058-ef39b40498680c5f29fffbeb88fef3e96b1d33b6.zip
optionally support parallel toolchain build. This defaults to off, because certain toolchain versions are known to break on parallel build. However, it significantly speeds up the build and latest versions of the tools do compile fine.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23196 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/toolchain-build.mk')
-rw-r--r--include/toolchain-build.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/toolchain-build.mk b/include/toolchain-build.mk
index 6defe63edf..a0bc4061fc 100644
--- a/include/toolchain-build.mk
+++ b/include/toolchain-build.mk
@@ -11,6 +11,8 @@ REAL_STAGING_DIR_HOST:=$(STAGING_DIR_HOST)
STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
+TOOLCHAIN_JOBS?=$(if $(CONFIG_TOOLCHAIN_PARALLEL),-j$(CONFIG_PKG_BUILD_JOBS))
+
include $(INCLUDE_DIR)/host-build.mk
HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared