aboutsummaryrefslogtreecommitdiffstats
path: root/include/toolchain-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-30 21:43:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-30 21:43:59 +0000
commita8311020d66c4da2c9052c5c9cd8df178cae3671 (patch)
tree085eb95b8263d0dbba9dfa6184ebcd453423bb06 /include/toolchain-build.mk
parentdfa9eeadb6d1815ada98d5c0f3fe6bd83e3ef3de (diff)
downloadmaster-187ad058-a8311020d66c4da2c9052c5c9cd8df178cae3671.tar.gz
master-187ad058-a8311020d66c4da2c9052c5c9cd8df178cae3671.tar.bz2
master-187ad058-a8311020d66c4da2c9052c5c9cd8df178cae3671.zip
toolchain: fix up lib64 symlink to lib before copying the initial prefix dir to avoid errors on copying
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32556 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/toolchain-build.mk')
-rw-r--r--include/toolchain-build.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/toolchain-build.mk b/include/toolchain-build.mk
index a0bc4061fc..d2fdb0281a 100644
--- a/include/toolchain-build.mk
+++ b/include/toolchain-build.mk
@@ -16,3 +16,12 @@ TOOLCHAIN_JOBS?=$(if $(CONFIG_TOOLCHAIN_PARALLEL),-j$(CONFIG_PKG_BUILD_JOBS))
include $(INCLUDE_DIR)/host-build.mk
HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared
+
+define FixupLibdir
+ if [ -d $(1)/lib64 -a \! -L $(1)/lib64 ]; then \
+ mkdir -p $(1)/lib; \
+ mv $(1)/lib64/* $(1)/lib/; \
+ rm -rf $(1)/lib64; \
+ fi
+ ln -sf lib $(1)/lib64
+endef