aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-18 17:03:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-18 17:03:55 +0000
commitf0f9ec9c5626a4124234638a0ed2f4c99c435ff8 (patch)
treeeaa59400aae15a69c47faa369e3bf53690f18592 /include/target.mk
parentba5b41f0dcd3b89ab6ff031147d99ec6d4a132ef (diff)
downloadmaster-187ad058-f0f9ec9c5626a4124234638a0ed2f4c99c435ff8.tar.gz
master-187ad058-f0f9ec9c5626a4124234638a0ed2f4c99c435ff8.tar.bz2
master-187ad058-f0f9ec9c5626a4124234638a0ed2f4c99c435ff8.zip
add a modified version of the mips64 patch from #4603
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15249 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 2f62c2a8cd..5484592def 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -155,6 +155,8 @@ ifeq ($(DUMP),1)
DEFAULT_CFLAGS_x86_64=-O2 -pipe -march=athlon64 -funit-at-a-time
DEFAULT_CFLAGS_mips=-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time
DEFAULT_CFLAGS_mipsel=$(DEFAULT_CFLAGS_mips)
+ DEFAULT_CFLAGS_mips64=-Os -pipe -mips64 -mtune=mips64 -mabi=64 -funit-at-a-time
+ DEFAULT_CFLAGS_mips64el=$(DEFAULT_CFLAGS_mips64)
DEFAULT_CFLAGS_arm=-Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time
DEFAULT_CFLAGS_armeb=$(DEFAULT_CFLAGS_arm)
DEFAULT_CFLAGS=$(if $(DEFAULT_CFLAGS_$(ARCH)),$(DEFAULT_CFLAGS_$(ARCH)),-Os -pipe -funit-at-a-time)