aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-04-28 22:01:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-04-28 22:01:14 +0000
commitef0a202a8f52384d143a043834495bd1b0df6148 (patch)
treeb43759ba09d9f8fd85b767350fab10987e165f09 /include/target.mk
parent9d3a3c4595fb59fa06b474d75649c53a3e6729c5 (diff)
downloadmaster-187ad058-ef0a202a8f52384d143a043834495bd1b0df6148.tar.gz
master-187ad058-ef0a202a8f52384d143a043834495bd1b0df6148.tar.bz2
master-187ad058-ef0a202a8f52384d143a043834495bd1b0df6148.zip
add optional version suffix to kernel files/ directories
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10972 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index ce842da795..7010424b43 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -106,6 +106,7 @@ include $(INCLUDE_DIR)/kernel-version.mk
GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic-$(KERNEL)
GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(shell [ -d "$(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
+GENERIC_FILES_DIR := $(GENERIC_PLATFORM_DIR)/files$(shell [ -d "$(GENERIC_PLATFORM_DIR)/files-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
GENERIC_LINUX_CONFIG?=$(firstword $(wildcard $(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER) $(GENERIC_PLATFORM_DIR)/config-default))
LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)))