aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-31 09:30:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-31 09:30:03 +0000
commiteb8df511575d55ec4f9a7e4d17e0448f226089c0 (patch)
tree9dc051c92dd15b97734633471352c41f805cff62 /include/target.mk
parentee2c166595c82e6069159527d3fec8f4e1d298fe (diff)
downloadmaster-187ad058-eb8df511575d55ec4f9a7e4d17e0448f226089c0.tar.gz
master-187ad058-eb8df511575d55ec4f9a7e4d17e0448f226089c0.tar.bz2
master-187ad058-eb8df511575d55ec4f9a7e4d17e0448f226089c0.zip
target.mk: add optimization flags for MIPS 24Kc.
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47323 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index f8c0d2386d..798805604c 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -212,6 +212,7 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_mips32 = -mips32 -mtune=mips32
CPU_CFLAGS_mips32r2 = -mips32r2 -mtune=mips32r2
CPU_CFLAGS_mips64 = -mips64 -mtune=mips64 -mabi=64
+ CPU_CFLAGS_24kc = -mips32r2 -mtune=24kc
CPU_CFLAGS_24kec = -mips32r2 -mtune=24kec
CPU_CFLAGS_34kc = -mips32r2 -mtune=34kc
CPU_CFLAGS_74kc = -mips32r2 -mtune=74kc