aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-09-26 17:53:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-09-26 17:53:32 +0000
commitbe6662ecdf8af0de61a610f71bd62e3157800bcb (patch)
tree849fdb2994ed9fc322536f52c93263674209798c /include/target.mk
parent9f5f79d806bbdc3c834f9c05e26b99e82519a4c9 (diff)
downloadmaster-187ad058-be6662ecdf8af0de61a610f71bd62e3157800bcb.tar.gz
master-187ad058-be6662ecdf8af0de61a610f71bd62e3157800bcb.tar.bz2
master-187ad058-be6662ecdf8af0de61a610f71bd62e3157800bcb.zip
build: include the cpu type as part of the toolchain/target directory name
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38214 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index c3b4c52459..4e7fdf7b90 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -254,6 +254,7 @@ define BuildTargets/DumpCurrent
echo 'Target-Features: $(FEATURES)'; \
echo 'Target-Depends: $(DEPENDS)'; \
echo 'Target-Optimization: $(if $(CFLAGS),$(CFLAGS),$(DEFAULT_CFLAGS))'; \
+ echo 'CPU-Type: $(CPU_TYPE)$(if $(CPU_SUBTYPE),+$(CPU_SUBTYPE))'; \
echo 'Linux-Version: $(LINUX_VERSION)'; \
echo 'Linux-Release: $(LINUX_RELEASE)'; \
echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \