aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-04-20 09:46:45 +0000
committerNicolas Thill <nico@openwrt.org>2008-04-20 09:46:45 +0000
commitb21db46a8e69044a809fb93ea5494d273d43b74f (patch)
treee0cd86d40efcbda38c405d27b8b68872faaf7a8a /include/target.mk
parent2d93f878d281c88557f10020bc0bb6c715aa6ce6 (diff)
downloadmaster-187ad058-b21db46a8e69044a809fb93ea5494d273d43b74f.tar.gz
master-187ad058-b21db46a8e69044a809fb93ea5494d273d43b74f.tar.bz2
master-187ad058-b21db46a8e69044a809fb93ea5494d273d43b74f.zip
add a gpio feature for devices supporting the generic GPIO interface
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10879 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 4f10a3db2b..ce842da795 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -126,6 +126,9 @@ ifeq ($(DUMP),1)
.SILENT: $(TMP_CONFIG)
.PRECIOUS: $(TMP_CONFIG)
+ ifneq ($(CONFIG_GENERIC_GPIO),)
+ FEATURES += gpio
+ endif
ifneq ($(CONFIG_PCI),)
FEATURES += pci
endif