aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-11 01:25:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-11 01:25:06 +0000
commit9a724ec84e675b6a625efa3eb9b1d906759c4aeb (patch)
tree07dee3c07ba60a709824992f98610da5357fd0f7 /include/target.mk
parenta228d3f366975e263d3acb7ab6596dbf0fb1f73b (diff)
downloadmaster-187ad058-9a724ec84e675b6a625efa3eb9b1d906759c4aeb.tar.gz
master-187ad058-9a724ec84e675b6a625efa3eb9b1d906759c4aeb.tar.bz2
master-187ad058-9a724ec84e675b6a625efa3eb9b1d906759c4aeb.zip
merge target kernel config files with subtarget config files and add a variable override for editing the target kernel config file with make kernel_menuconfig in case the subtarget contains overrides (thx, sn9)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18362 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index b30be1032e..2bfb702788 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -115,7 +115,7 @@ GENERIC_FILES_DIR := $(foreach dir,$(wildcard $(GENERIC_PLATFORM_DIR)/files $(GE
GENERIC_LINUX_CONFIG?=$(firstword $(wildcard $(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER) $(GENERIC_PLATFORM_DIR)/config-default))
LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)) $(PLATFORM_DIR)/config-$(KERNEL_PATCHVER))
-LINUX_SUBCONFIG?=$(firstword $(wildcard $(PLATFORM_SUBDIR)/config-$(KERNEL_PATCHVER) $(PLATFORM_SUBDIR)/config-default))
+LINUX_SUBCONFIG?=$(if $(SHARED_LINUX_CONFIG),,$(firstword $(wildcard $(PLATFORM_SUBDIR)/config-$(KERNEL_PATCHVER) $(PLATFORM_SUBDIR)/config-default)))
ifeq ($(LINUX_CONFIG),$(LINUX_SUBCONFIG))
LINUX_SUBCONFIG:=
endif