aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-02-12 15:43:14 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-02-12 15:43:14 +0000
commit9a2f69609c686af0c93b5a18bde2bfd2e1e8d5c6 (patch)
tree21f9363f43202f9c7e2e1391b014e8fcfd0ba66b /include/target.mk
parentf8a6d9d74e24a1d5c936007542c0d61b6cab8bbb (diff)
downloadmaster-187ad058-9a2f69609c686af0c93b5a18bde2bfd2e1e8d5c6.tar.gz
master-187ad058-9a2f69609c686af0c93b5a18bde2bfd2e1e8d5c6.tar.bz2
master-187ad058-9a2f69609c686af0c93b5a18bde2bfd2e1e8d5c6.zip
handle "neon" fpu type
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39579 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 20347e9b01..79d52f0b84 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -232,6 +232,7 @@ ifeq ($(DUMP),1)
CPU_CFLAGS_mpcore = -march=armv6k -mtune=mpcore
CPU_CFLAGS_xscale = -march=armv5te -mtune=xscale
ifeq ($(CONFIG_SOFT_FLOAT),)
+ CPU_CFLAGS_neon = -mfpu=neon
CPU_CFLAGS_vfp = -mfpu=vfp
CPU_CFLAGS_vfpv3 = -mfpu=vfpv3-d16
endif