aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-03 14:55:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-03 14:55:53 +0000
commit937f1820f2936d3940240b1cb77b094fd4086df9 (patch)
treecb5eba0e4f6e22e81665e3ef321d102d1ca321fc /include/target.mk
parenta01125e51b4c7e66db0fc72bf8d10698e4f536c6 (diff)
downloadmaster-187ad058-937f1820f2936d3940240b1cb77b094fd4086df9.tar.gz
master-187ad058-937f1820f2936d3940240b1cb77b094fd4086df9.tar.bz2
master-187ad058-937f1820f2936d3940240b1cb77b094fd4086df9.zip
replace a few unnecessary $(shell) calls
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14739 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index d3c149aa18..ace3db0ffd 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -109,7 +109,7 @@ ifneq ($(TARGET_BUILD)$(if $(DUMP),,1),)
endif
GENERIC_PLATFORM_DIR := $(TOPDIR)/target/linux/generic-$(KERNEL)
-GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(shell [ -d "$(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
+GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(if $(wildcard $(GENERIC_PLATFORM_DIR)/patches-$(KERNEL_PATCHVER)),-$(KERNEL_PATCHVER))
GENERIC_FILES_DIR := $(foreach dir,$(wildcard $(GENERIC_PLATFORM_DIR)/files $(GENERIC_PLATFORM_DIR)/files-$(KERNEL_PATCHVER)),"$(dir)")
GENERIC_LINUX_CONFIG?=$(firstword $(wildcard $(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER) $(GENERIC_PLATFORM_DIR)/config-default))