aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-06-13 15:28:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-06-13 15:28:31 +0000
commit2fb4a47e9aa0f79addeb6d2be38731c1809d94e5 (patch)
treea2e025ed375dcc0ae589d01b8b88f22d7ddd6580 /include/target.mk
parent3a02933ef3b70464c54d01bf56b3cb16cac767f7 (diff)
downloadmaster-187ad058-2fb4a47e9aa0f79addeb6d2be38731c1809d94e5.tar.gz
master-187ad058-2fb4a47e9aa0f79addeb6d2be38731c1809d94e5.tar.bz2
master-187ad058-2fb4a47e9aa0f79addeb6d2be38731c1809d94e5.zip
create a platform config-* file if there is none already when running kernel_menuconfig or kernel_oldconfig
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11460 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index be9f128cda..8b123959d3 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -109,7 +109,7 @@ GENERIC_PATCH_DIR := $(GENERIC_PLATFORM_DIR)/patches$(shell [ -d "$(GENERIC_PLAT
GENERIC_FILES_DIR := $(GENERIC_PLATFORM_DIR)/files$(shell [ -d "$(GENERIC_PLATFORM_DIR)/files-$(KERNEL_PATCHVER)" ] && printf -- "-$(KERNEL_PATCHVER)" || true )
GENERIC_LINUX_CONFIG?=$(firstword $(wildcard $(GENERIC_PLATFORM_DIR)/config-$(KERNEL_PATCHVER) $(GENERIC_PLATFORM_DIR)/config-default))
-LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)))
+LINUX_CONFIG?=$(firstword $(wildcard $(foreach subdir,$(PLATFORM_DIR) $(PLATFORM_SUBDIR),$(subdir)/config-$(KERNEL_PATCHVER) $(subdir)/config-default)) $(PLATFORM_DIR)/config-$(KERNEL_PATCHVER))
LINUX_SUBCONFIG?=$(firstword $(wildcard $(PLATFORM_SUBDIR)/config-$(KERNEL_PATCHVER) $(PLATFORM_SUBDIR)/config-default))
ifeq ($(LINUX_CONFIG),$(LINUX_SUBCONFIG))
LINUX_SUBCONFIG:=