aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-11-22 12:01:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-11-22 12:01:01 +0000
commit27bb4475fb3c45571ca084c5903e3eeca68d018e (patch)
tree7f3b0c4f159dcf61069c425d3d16f37230a4b1f0 /include/target.mk
parentf23c2eafda6affcfab9047866d23c5e6c9df9e13 (diff)
downloadmaster-187ad058-27bb4475fb3c45571ca084c5903e3eeca68d018e.tar.gz
master-187ad058-27bb4475fb3c45571ca084c5903e3eeca68d018e.tar.bz2
master-187ad058-27bb4475fb3c45571ca084c5903e3eeca68d018e.zip
add a feature flag for device tree support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38893 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 467ef35766..acb9adf584 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -167,6 +167,9 @@ ifeq ($(DUMP),1)
.SILENT: $(TMP_CONFIG)
.PRECIOUS: $(TMP_CONFIG)
+ ifneq ($(CONFIG_OF),)
+ FEATURES += dt
+ endif
ifneq ($(CONFIG_GENERIC_GPIO)$(CONFIG_GPIOLIB),)
FEATURES += gpio
endif