aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:37 +0000
commit14be67809466ef612e619b7d8b1e8df42b4e075b (patch)
tree016fc4de832be636e9af52b9bebfc45308c65194 /include/target.mk
parent6e39367d4faefe4d03e91495f9a174019bd8ddab (diff)
downloadmaster-187ad058-14be67809466ef612e619b7d8b1e8df42b4e075b.tar.gz
master-187ad058-14be67809466ef612e619b7d8b1e8df42b4e075b.tar.bz2
master-187ad058-14be67809466ef612e619b7d8b1e8df42b4e075b.zip
speed up the build system by including include/shell.sh on shell commands only where necessary
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22720 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/target.mk b/include/target.mk
index 2f45bd877c..d49714c353 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -67,10 +67,10 @@ define Profile
echo "Target-Profile-Kconfig: yes"; \
fi; \
echo "Target-Profile-Config: "; \
- getvar "$(call shvar,Profile/$(1)/Config)"; \
+ $(SH_FUNC) getvar "$(call shvar,Profile/$(1)/Config)"; \
echo "@@"; \
echo "Target-Profile-Description:"; \
- getvar "$(call shvar,Profile/$(1)/Description)"; \
+ $(SH_FUNC) getvar "$(call shvar,Profile/$(1)/Description)"; \
echo "@@"; \
echo;
ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_)$(1))),y)
@@ -185,7 +185,7 @@ define BuildTargets/DumpCurrent
echo 'Linux-Release: $(LINUX_RELEASE)'; \
echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \
echo 'Target-Description:'; \
- getvar $(call shvar,Target/Description); \
+ $(SH_FUNC) getvar $(call shvar,Target/Description); \
echo '@@'; \
echo 'Default-Packages: $(DEFAULT_PACKAGES)'; \
$(DUMPINFO)